易语言入门抽奖摇数字

抽奖摇数字

黑白课堂
这个我们需要4个时钟就可以搞定了。
原理很简单,使用4个时钟,然后给每个时钟设置延迟时钟周期,错开周期,最后到一定时间,全部周期为0,那么周期不动了,数字就不动,那么就是抽奖的结果了。

代码组件

黑白课堂

  • 时钟
  • 窗口背景图片
  • 图片按钮
.版本 2
.支持库 iext
.支持库 EThread

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

.子程序 子程序1

时钟1.时钟周期 = 200
延时 (1000)
时钟1.时钟周期 = 100
延时 (1000)
时钟2.时钟周期 = 200
延时 (1000)
时钟1.时钟周期 = 50
延时 (1000)
时钟2.时钟周期 = 100
延时 (1000)
时钟3.时钟周期 = 200
延时 (1000)
时钟2.时钟周期 = 50
延时 (1000)
时钟3.时钟周期 = 100
延时 (1000)
时钟4.时钟周期 = 200
延时 (1000)
时钟3.时钟周期 = 50
延时 (1000)
时钟4.时钟周期 = 100
延时 (1000)
时钟4.时钟周期 = 50
延时 (3000)
时钟1.时钟周期 = 0
延时 (1000)
时钟2.时钟周期 = 0
延时 (1000)
时钟3.时钟周期 = 0
延时 (1000)
时钟4.时钟周期 = 0
_启动窗口.标题 = “开奖号:” + 透明标签1.标题 + 透明标签2.标题 + 透明标签3.标题 + 透明标签4.标题
透明标签5.标题 = “恭喜编号 (” + 透明标签1.标题 + 透明标签2.标题 + 透明标签3.标题 + 透明标签4.标题 + “) 中奖”

.子程序 _时钟1_周期事件

.如果 (到整数 (透明标签1.标题) = 9)
    透明标签1.标题 = “0”
.否则
    透明标签1.标题 = 到文本 (到整数 (透明标签1.标题) + 1)
.如果结束

.子程序 _时钟2_周期事件

.如果 (到整数 (透明标签2.标题) = 9)
    透明标签2.标题 = “0”
.否则
    透明标签2.标题 = 到文本 (到整数 (透明标签2.标题) + 1)
.如果结束

.子程序 _时钟4_周期事件

.如果 (到整数 (透明标签4.标题) = 9)
    透明标签4.标题 = “0”
.否则
    透明标签4.标题 = 到文本 (到整数 (透明标签4.标题) + 1)
.如果结束

.子程序 _时钟3_周期事件

.如果 (到整数 (透明标签3.标题) = 9)
    透明标签3.标题 = “0”
.否则
    透明标签3.标题 = 到文本 (到整数 (透明标签3.标题) + 1)
.如果结束

.子程序 _图片框1_鼠标左键被按下, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

启动线程 (&子程序1, , )

当然我们还可以增加一个按钮,例如手动停止按钮,把全部时钟变成0即可。

更改版本

黑白课堂

.版本 2
.支持库 iext
.支持库 EThread

.程序集 窗口程序集_启动窗口
.程序集变量 线程句柄, 整数型

.子程序 __启动窗口_创建完毕

.子程序 子程序1

时钟1.时钟周期 = 200
延时 (1000)
时钟1.时钟周期 = 100
延时 (1000)
时钟2.时钟周期 = 200
延时 (1000)
时钟1.时钟周期 = 50
延时 (1000)
时钟2.时钟周期 = 100
延时 (1000)
时钟3.时钟周期 = 200
延时 (1000)
时钟2.时钟周期 = 50
延时 (1000)
时钟3.时钟周期 = 100
延时 (1000)
时钟4.时钟周期 = 200
延时 (1000)
时钟3.时钟周期 = 50
延时 (1000)
时钟4.时钟周期 = 100
延时 (1000)
时钟4.时钟周期 = 50
延时 (3000)
时钟1.时钟周期 = 0
延时 (1000)
时钟2.时钟周期 = 0
延时 (1000)
时钟3.时钟周期 = 0
延时 (1000)
时钟4.时钟周期 = 0
_启动窗口.标题 = “开奖号:” + 透明标签1.标题 + 透明标签2.标题 + 透明标签3.标题 + 透明标签4.标题
透明标签5.标题 = “恭喜编号 (” + 透明标签1.标题 + 透明标签2.标题 + 透明标签3.标题 + 透明标签4.标题 + “) 中奖”

.子程序 _时钟1_周期事件

.如果 (到整数 (透明标签1.标题) = 9)
    透明标签1.标题 = “0”
.否则
    透明标签1.标题 = 到文本 (到整数 (透明标签1.标题) + 1)
.如果结束

.子程序 _时钟2_周期事件

.如果 (到整数 (透明标签2.标题) = 9)
    透明标签2.标题 = “0”
.否则
    透明标签2.标题 = 到文本 (到整数 (透明标签2.标题) + 1)
.如果结束

.子程序 _时钟4_周期事件

.如果 (到整数 (透明标签4.标题) = 9)
    透明标签4.标题 = “0”
.否则
    透明标签4.标题 = 到文本 (到整数 (透明标签4.标题) + 1)
.如果结束

.子程序 _时钟3_周期事件

.如果 (到整数 (透明标签3.标题) = 9)
    透明标签3.标题 = “0”
.否则
    透明标签3.标题 = 到文本 (到整数 (透明标签3.标题) + 1)
.如果结束

.子程序 _图片框1_鼠标左键被按下, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

启动线程 (&子程序1, , 线程句柄)

.子程序 _按钮1_被单击

强制结束线程 (线程句柄)
时钟1.时钟周期 = 0
时钟2.时钟周期 = 0
时钟3.时钟周期 = 0
时钟4.时钟周期 = 0
_启动窗口.标题 = “开奖号:” + 透明标签1.标题 + 透明标签2.标题 + 透明标签3.标题 + 透明标签4.标题
透明标签5.标题 = “恭喜编号 (” + 透明标签1.标题 + 透明标签2.标题 + 透明标签3.标题 + 透明标签4.标题 + “) 中奖”

原理很简单,就是强制关闭我们的线程,这样就避免线程继续执行。

评论区 (0)

没有记录
支持 markdown,图片截图粘贴拖拽都可以自动上传。
空气

空气 · 中级学士

热卖技术,喜欢新东西。

魔童降世
查看更多

最新视频课程

钻级赞助商