易语言入门判断文件夹是否存在的方法

判断文件夹是否存在的方法

这里整理4个方法

  • 对象检测
  • 用改变目录检测文件夹是否存在
  • 用API检测文件夹是否存在
  • 寻找文件检测

黑白课堂

.版本 2

.程序集 窗口程序集1

.子程序 _按钮1_被单击
.局部变量 SFO, 对象
.局部变量 路径, 文本型

.如果真 (SFO.创建 (“scripting.FileSystemObject”, ))
    路径 = “C:\windows”
    .如果真 (SFO.读文本属性 (“FolderExists”, 路径 ) ≠ “0”)
        信息框 (“文件夹存在”, 0, )
        返回 ()
    .如果真结束
    信息框 (“文件夹不存在”, 0, )
.如果真结束

.子程序 _按钮2_被单击
.局部变量 路径, 文本型

路径 = “C:\windows”
.如果真 (PathIsDirectory ( 路径 ) ≠ 0)
    信息框 (“文件夹存在”, 0, )
    返回 ()
.如果真结束
信息框 (“文件夹不存在”, 0, )

.子程序 _按钮3_被单击
.局部变量 路径, 文本型

路径 = “C:\windows”
.如果真 ( 改变目录 ( 路径 ))
    信息框 (“文件夹存在”, 0, )
    返回 ()
.如果真结束
信息框 (“文件夹不存在”, 0, )

.子程序 _按钮4_被单击
.局部变量 路径, 文本型

路径 = “C:\windows”
.如果真 ( 寻找文件 ( 路径, #子目录 ) ≠ “”)
    信息框 (“文件夹存在”, 0, )
    返回 ()
.如果真结束
信息框 (“文件夹不存在”, 0, )

.子程序 __启动窗口_创建完毕

dll 命令

黑白课堂

.版本 2

.DLL命令 PathIsDirectory, 整数型, "shlwapi.dll", "PathIsDirectoryA"
    .参数 lpszPath, 文本型

评论区 (0)

没有记录
支持 markdown,图片截图粘贴拖拽都可以自动上传。
空气

空气 · 中级学士

热卖技术,喜欢新东西。

魔童降世
查看更多

最新视频课程

钻级赞助商