易语言入门进度条的使用

易语音进度条的使用

模拟下载例子
黑白课堂

拆分组件
黑白课堂

  • 时钟模拟下载进程
  • 进度条组件
  • 按钮

逻辑

首先设置进度条的总长度,然后在时间周期,判断进度条的位置,每个周期进度条位置都要改变,百分 比,则计算当前位置/总长度即可

.版本 2
.支持库 spec

.程序集 窗口程序集1
.程序集变量 n, 整数型
.程序集变量 total, 整数型

.子程序 _按钮1_被单击

.如果 ( 时钟1.时钟周期 = 10)
    时钟1.时钟周期 = 0
    按钮1.标题 = “开始”

.否则
    时钟1.时钟周期 = 10
    按钮1.标题 = “停止”
.如果结束

.子程序 _时钟1_周期事件

n = 1 + n
进度条1.位置 = n
调试输出 ( 进度条1.位置 )
.如果真 ( 进度条1.位置 = total)
    信息框 (“下载完成”, 0, )
    销毁 ()
.如果真结束
.如果 ( 进度条1.位置 ≤ total)
    标签2.标题 = 到文本 ( 进度条1.位置 ÷ total × 100) + “%”
.否则
    标签2.标题 = “100%”
.如果结束

.子程序 __启动窗口_创建完毕

total = 1000

评论区 (0)

没有记录
支持 markdown,图片截图粘贴拖拽都可以自动上传。
空气

空气 · 中级学士

热卖技术,喜欢新东西。

魔童降世
查看更多

最新视频课程

钻级赞助商