易语言入门通用对话框导入文件

通用对话框导入文件

界面要求
黑白课堂

  • 超级列表
  • 通用对话框
  • 按钮

逻辑

  • 清空列表
  • 弹出对话框,过滤文件
  • 读入文件
  • 读入文字,切割文字
  • 写入超级列表框
.版本 2
.支持库 iext

超级列表框1.全部删除 ()  ' 清空列表框中的数据
通用对话框1.类型 = 0  ' 对话框的类型(可忽略,在组件中设置)
通用对话框1.过滤器 = “文本文档|*.txt”  ' 打开文件的类型
通用对话框1.初始目录 = 取运行目录 ()  ' 对话框打开后自动转跳的目录(可忽略)
.如果真 ( 通用对话框1.打开 ())  ' 判断打开对话框后是否有选择项目,对话框必须要打开,否则以下代码都没用
    文本 = 分割文本 ( 到文本 ( 读入文件 ( 通用对话框1.文件名 )), #换行符, )  ' 读取对话框所选择的文件全路径名,把指定项目中的每个账号分割出来
    .计次循环首 ( 取数组成员数 ( 文本 ), i)  ' 循环把指定项目中的数据全部插入,循环数组文本的成员数,循环次数保存在i
        信息 = 分割文本 ( 文本 [i], “----”, 2)  '分割文本第i个成员,把他分割成账号和密码(不能使用前面那个数组,容量不够了)' 调试输出 ( 信息 [1])
        第几个 = 超级列表框1.插入表项 (, , , , , )  
        ' “第几个”变量保存返回新表项的位置索引,给后面使用的。
        超级列表框1.置标题 ( 第几个, 0, 到文本 (i))  ' 插入列表框的序号,数组下标从1开始
        超级列表框1.置标题 ( 第几个, 1, 信息 [1])  ' 插入信息中的账号,数组信息的第一个成员
        超级列表框1.置标题 ( 第几个, 2, 信息 [2])  ' 插入信息中的密码,数组信息的第二个成员
    .计次循环尾 ()  ' 计次循环的尾巴

导入文件格式

18344xxx----xxxxx

黑白课堂

评论区 (0)

没有记录
支持 markdown,图片截图粘贴拖拽都可以自动上传。
空气

空气 · 中级学士

热卖技术,喜欢新东西。

魔童降世
查看更多

最新视频课程

钻级赞助商